Eclipse 2018-09在Windows 10上使用OpenJDK 11

最后发布: 2018-09-26 14:45:31


问题

我刚刚在Windows 10上安装了OpenJDK版本的JDK 11通用可用性版本 。我尝试在刚刚发布的Eclipse 2018-09(4.9.0)中将其作为JRE安装,并在Eclipse对话框中显示一条消息:

您选择了此版本的Eclipse JDT尚未完全支持的JRE。 某些功能可能无法正常工作。

问题是什么?

  • Eclipse 2018-09不完全支持JDK 11吗?
  • 或者是Eclipse不完全支持OpenJDK 11但是支持Oracle JDK 11?
  • 特别是“功能”可以指望“不按预期工作”?

更新:从Internet搜索,我发现一些代码似乎表明Eclipse有一个已知Java版本的内部列表,如果新的JDK版本的版本高于已知的Java版本,它会给出上述消息。 (这就是我解释代码的方式。)真的吗? Eclipse发布了一个新的2018-09版本,就在JDK 11发布前几天,没有更新其已知Java版本列表以包含Java 11?

也许某人有更权威的答案。

java eclipse java-11 eclipse-2018-09
回答

Eclipse 2018-09不支持开箱即用的JDK 11,但JDK 11的官方插件现已在市场上发布:

https://marketplace.eclipse.org/content/java-11-support-eclipse-2018-09-49

以下是发布公告: https//www.eclipse.org/lists/jdt-dev/msg01049.html

支持OracleJDK和OpenJDK的方式相同(OpenJ9等其他JDK也可以使用)

如果不支持新的JDK版本,则无法使用其新的语言功能,并且由于类格式更改,您可能无法将其全部用于开发。 启动可能会起作用。


回答

2018-09插件的更新站点位于: http//download.eclipse.org/eclipse/updates/4.9-P-builds/P20180926-0920/