在Ubuntu 18.04.2上安装libgpg-error-1.11错误

最后发布: 2019-06-02 16:11:50


问题

我需要libgcrypt-1.6.3进行我想做的实验。 安装libgcrypt时我注意到我缺少libgpg-error版本1.11:

checking for GPG Error - version >= 1.11... no
configure: error: libgpg-error is needed.
                See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .

所以我从这个链接下载了包,并按照README文件中的说明运行./configure 它完成配置并打印出来:

  libgpg-error-1.11 prepared for make 

然后我运行make ,这就是我得到多个错误抱怨以下内容的地方:

./mkerrcodes.h:114:5: error: expected expression before ‘,’ token

我不知道问题出在哪里。 是否由于与我正在安装它的架构有任何不兼容?

ubuntu libgcrypt libgpg-error