NU1202:MySql.Data.Entity与monoandroid81不兼容

最后发布: 2019-05-12 16:48:59


问题

我正在尝试启动我的第一个Xamarin项目,并且在尝试安装MySqlEntity NuGet软件包时遇到了一些问题。

严重性代码说明项目文件行抑制状态错误NU1202程序包MySql.Data.Entity 6.10.8与monoandroid81(MonoAndroid,Version = v8.1)不兼容。 软件包MySql.Data.Entity 6.10.8支持:net452(.NETFramework,Version = v4.5.2)Refo_T3.Android C:\\ Users \\ evyat \\ source \\ repos \\ Refo_T3 \\ Refo_T3 \\ Refo_T3.Android \\ Refo_T3.Android.csproj 1

我尝试了以下解决方案: Xamarin.Android:软件包XX与monoandroid81(MonoAndroid,Version = v8.1)不兼容,并且仍然出现错误。


这是我在Xamarin平台上的第一个应用程序,我曾经在.NET进行编码,但是我决定使用Xamarin测试自己的运气。

我在网上找不到更多有用的信息,我需要您更好的经验。 谢谢 :)

mysql xamarin xamarin.forms xamarin.android mysql-workbench
回答

正如在nuget软件包页面所写 ,该软件包仅适用于> = 4.5.2的.net framework。

在此处输入图片说明

因此,您不能仅针对经典桌面.Net Framework应用程序为Xamarin Android项目安装它。